Ещё

В беспроводном сетевом оборудовании Cambium обнаружены серьезные уязвимости 

Исследователь безопасности Карн Ганесхен (Karn Ganeshen) обнаружил более 10 уязвимостей в беспроводном сетевом оборудовании ePMP и cnPilot от компании Cambium Networks. Уязвимости могут быть проэксплуатированы злоумышленником для управления устройствами и сетями, к которым они подключены.
Беспроводные широкополосные решения Cambium ePMP и cnPilot используются правительствами, розничными торговцами, интернет-провайдерами, гостиницами, школами, предприятиями и промышленными организациями.
Как выяснил исследователь, уязвимости затрагивают беспроводные широкополосные устройства ePMP 1000, 2000 и Force, а также точки доступа Wi-Fi cnPilot R190, R200 и R201. Несмотря на то, что для эксплуатации уязвимостей, как правило, необходим локальный доступ, исследователям безопасности из компании Rapid7 удалось обнаружить более 36 тыс. устройств ePMP и 133 системы cnPilot, доступных через интернет. Наибольшее количество незащищенных систем наблюдалось в Сербии (9,6 тыс.), США (8,2 тыс.), Италии (5 тыс.), Бразилии (3 тыс.), Испании (2,7 тыс.), Колумбии (2,5 тыс.) и Южной Африке (1,1 тыс.).
Одной из опасных уязвимостей является проблема эскалации привилегий CVE-2017-5254, затрагивающая устройства ePMP. Данные системы поставляются с несколькими учетными записями с установлеными логинами и паролями по умолчанию, в частности admin/admin, installer/installer, home/home и readonly/readonly. У учетных записей home и installer нет прав администратора, однако Ганесхен обнаружил, что их можно использовать для изменения пароля учетной записи администратора.
На данных устройствах пароль администратора не может быть изменен пользователем, поскольку поле пароля не редактируется. Однако злоумышленник, получивший доступ к web-интерфейсу учетных записей home и installer, может использовать функцию Inspect Element в браузере и удалить свойство disabled = "", сделав поле пароля редактируемым. Затем злоумышленник может установить свой пароль и использовать его для доступа к web-интерфейсу с правами администратора.
Еще одна опасная уязвимость эскалации привилегий в ePMP (CVE-2017-5255) позволяет аутентифицированному злоумышленнику выполнять команды с правами суперпользователя, отправив специально сформированный запрос к функции get_chart.
Помимо этого, хакер также может повысить привилегии на устройстве ePMP, используя уязвимости межсайтового скриптинга (XSS) в полях «Имя устройства» и «Описание системы». Злоумышленник, имеющий доступ к web-интерфейсу устройства, может внедрить вредоносный код JavaScript в эти поля. Таким образом код выполняется как в процессе авторизации, так и после того, как пользователь авторизовался.
Наиболее серьезная уязвимость (CVE-2017-5259), обнаруженная в устройстве cnPilot, связана с незадокументированной корневой web-оболочкой, к которой может получить доступ любой пользователь. Другая проблема (CVE-2017-5260) в cnPilot позволяет повысить привилегии путем эксплуатации уязвимости (CVE-2017-5260) типа direct object reference (прямая ссылка на объект).
Уязвимости затрагивают продукты ePMP версии 3.5 и более ранние, а также cnPilot версии 4.3.2-R4 и ниже. Уязвимости были исправлены с выпуском версий 3.5.1 и 4.4 соответственно. Две уязвимости, связанные с отсутствием защиты от межсайтовой подделки запроса, не были исправлены.
Комментарии
Читайте также
Новости партнеров
Больше видео